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1" Plant design & optimization

Create factory models faster
& ensure they operate at
peak efficiency before
production ramp-up

» Factory design and analysis
»Material handling & costing

» Throughput simulation

»Order sequencing optimization
»Digital layout and design
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Factory Design & Optimization

» FactoryCAD: easiest method of authoring intelligent 3D models
of facilities — facilitates quicker, more cost effective
manufacturing launch

» FactoryFLOW: material handling tool to reduce non-value
added work, minimizes indirect labor costs, and helps realize
lean manufacturing objectives

» Plant Simulation: Discrete Event Simulation tool for statistical : ’ﬁ
modeling of facilities where throughput, machine capacity o —
constraints, queuing constraints, etc are important ,

» Plant Simulation FactoryCAD / SDX: discrete event simulation Y o~ —'JF
on top of 3D FactoryCAD factory models 13 y.. |

» eM-Designer Logistics: Toolset to plan and design supply ﬂr_— ! ! d":‘j— -
chains ' '

- o

» eM-Sequencer: constraint based decisions tool to optimize N
production sequences

» Factory Mockup: share, walk through, evaluate and animate
models of 3D virtual factory

» ICE: In Context Editor — Managing factory layout designs in
Teamcenter

» FIRM: FactoryCAD Integrated Resource Management —
Managing FactoryCAD equipment objects in Teamcenter RM
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Transforming the
process of innovation

% Introducing FactoryCAD
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FactoryCAD overview

» Turn AutoCAD into a
factory design tool

» Work with parametric
models of factory
equipment

» Create custom objects to
model unique equipment

» Import/export data to bring
product, tooling & plant
data together

» Complete a 3D factory
model quickly and easily
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9~ FactoryCAD savings

» Reduce tooling and equipment change
costs by 15% or more

» Reduce layout creation costs by 30%

» Save time - 90% reduction in 3D models,

30% reduction in 2D drawings; complete
layout designs in weeks instead of
months

Method Time

Solid models 3 + months
Plain AutoCAD 1-3 months
FactoryCAD 1-3 weeks
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FactoryCAD — Smart Factory Objects

» Drop, drag, stretch and connect together

» Fast and easy to add and position

» Objects contain built-in intelligence

» Very small file sizes compared to other solutions

» Hundreds of equipment configurations
P
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4~ FactoryCAD
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Create your own custom

» Parametric object and
system toolkit built into
FactoryCAD

» Create your own simple
parametric objects in XML

» Build in intelligence using
design rules and customize
object-to-object interaction

» XML objects can be
combined to form complex
systems

© UGS Corp. 2005. All rights reserved.
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Leverage existing tooling and

product data

» Start with 3D CAD model

» Convert to JT or Parasolid OR

» Use NX or Solid Edge in native format

» Read product data into FactoryCAD

» Lightweight
» 2D/3D views

» Add simulation and cost data

11
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Teamcenter connectivity e, o
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» FactoryCAD objects store gy e —
data that can be exported :
to simulation programs

NONE -
NONE -

» Create part routing
Information with built-in
SDX editor

12
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% Introducing Factory Mockup

13
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Y~ Factory Mockup

» Improves factory design
communication by providing
a CAD neutral environment
for collaboration

» ldentify collision and
clearance problems before
ordering and installing
equipment

» Reduces time required to
validate factory model
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Factory Mockup features

» Collaboration-friendly design
review environment

» Interactive viewing, walk,
and fly-through modes

» Measure, mark-up, object
manipulation

» Image and movie capture
tools

» Animation scripting

» Dynamic collision and
clearance violation detection

15
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Version 6.0 Transforming the

M Pl process of innovation
eM-rlant

% Plant Simulation

16
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1"_.. eM-Plant

» eM-Plant allows for creating a dynamic computer
model of a complex system (e.g. production) to
explore its characteristics and optimize the
performance of the system.

» The computer model enables user to run
experiments and what-if scenarios without disturbing
an existing production or — used in the planning
process — long before the real system is installed.

17
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»
9~ Benefits of simulation

» Detect and
that otherwise
would have required cost
and time consuming
correction measures
during the production
ramp-up

for production lines
without jeopardizing the
required output

> with
many variants

18
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1" Tecnomatix Plant Simulation

Real System / Plan Simulation-Model Simulation result

Ausbringungsmenge

» Transparent analysis of complex systems

» Calculation and comparison of real numbers

» Computer supported investment decisions

19
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» 3 -6 % savings on investment
(VDI, Association of German Engineers)

» Cost/ benefit ratio > 1: 12
(eM-Plant customer questionnaire)

» 15- 20 % productivity increase of existing systems
» 5-20 % reduced cost of new systems

» 20 - 60 % decreased throughput time and inventory
Average savings found in European market survey

20
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% Quick recap
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Q" FactoryCAD (3D plant modeling)

Features

» A 3D factory modeling and layout tool

» Provides over 150 types of smart objects of factory equipment such as
racks, cranes, conveyors, guardrails, paint booths.

WA

» The models holds cost, performance and process information, which can
be used by other applications

‘ Eya » Based on the Autodesk AutoCAD software
- . m“, !r‘L‘ 'Aq
| m— L » Provides 3D output in JT format
: » Reads in UG, Parasolid, JT data
» Allows user to create custom equipment objects
» Bill of Materials and Costing capability

» SDX (Simulation Data eXchange) enabled to link to DES systems
Benefits

» Allows the user to create layouts very quickly

» Creates a whole 3D factory model that is smaller in file size than a 2D
model

» Integrated with Teamcenter Manufacturing

» Brings Product data, Tooling data & Plant data together 22
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Plant Simulation (eM-Plant)

S
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Highlights

>

>

Allows for creating a computer model of a system (e.qg.
production) to explore its dynamic behavior

Optimize the performance (throughput) of the system and
minimizes investment costs

Enables user to run stochastic experiments

Conduct what-if scenarios without disturbing an existing
production

Use in the planning process — long before the real system
IS installed

Completely integrated with FactoryCAD — Single click
simulations from FactoryCAD

Ability to read in JT of the facility to run simulations on -
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Integrating 3D Plant Layout to Throughput Simulation
with Simulation Data eXchange (SDX)

24
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» Plant Design

» Static Simulation
» FactoryFLOW
» Discrete Event Simulation
» Spreadsheet
» Iconic 2-D
» Physical 3-D

» SDX — Simulation Data Exchange
» Need to channel data sources to DES
» History of SDX

» SDX — Simulation Data Exchange

» Brief overview

» FactoryCAD functionality supporting SDX

© UGS Corp. 2005. All rights reserved.
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1" Static Simulation

» Static Simulation — Inputs

» Assembly tree

» Individual part routings

» Containerization information

» Material Handling equipment definition

» Other miscellaneous details like load pickup and drop off....

‘-TIIF.E:J

/ FORR U”E ' FORKS Y FORK
- ': sentage

_

Process charts are used to specify material flow routings 26
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1" Static Simulation

» Static Simulation — Outputs

» Shortest travel path algorithms determine travel time
» Analyses are usually over a time period — day, shift, etc.
» Color coded material travel — showing intensity of travel

» Material handling utilization over a time period.

v
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1" Problem statement discussion

Real-world system

Medeling)
Coplecor

Simulation
model

Anashi [Stick]

Quantified results

28
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9~ The needs

» The layout is the hub of all change

» There Is a need to connect the layout community with
the throughput simulation team

» Need for shorter simulation / validation turn-around
times in iterative layout design process

» Need to focus throughput simulation experts’ efforts
In modeling instead of spending most of their time on
creating the model

» Enable knowledge capture and reuse — Cut down
duplication and repetitive tasks

» Allow more engineers to harness the power of
throughput simulation
29
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9~ The answer — SDX

» The SDX concept provides the data protocol and
fundamental connectivity between layout design and
throughput simulation

» Model Construction Functionality

» Utilize Smart Objects to quickly and easily create DES systems
» Define base movement system attributes in FactoryCAD

» Easy system design maintenance with one location (application)
for physical layout — no longer maintained in simulation and CAD

» No more redrawing system layout in the throughput simulation
tool

30
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1" SDX — Generic Architecture

Simulation ] Product Data
Objects 3D from different

Relevant
data FactoryCAD CAD systems

Process /
Part Routing
Database SDX File

Factory Mockup

w Visualization
Data Files
Discrete Event
Custom Code \\‘
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Simulation Mode
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9~ FactoryCAD to simulation

» How FactoryCAD data can be leveraged in Plant Simulation

ctoryCAD

Plant Simula

© UGS Corp. 2005. All rights reserved.



%“’, SDX Objects

Loads or Parts

Conveyors - Floor and Overhead
Vertical Lift Systems

Pivots & Cross Transfers

Aisles and Aisle Networks

Buffer

Runtime

Route

Process

Dock

Station Area

Shifts

Regular Monorail Systems
Transporters (Vehicles)
Carriers

Machines

Connection
Workcenter

Statistics

Labor

Robot

Gantry

All industrial objects

27 classes and growing... a3
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Y~ Sample of SDX properties

» Machines

Name, Type and Internal Type

Breakdowns - multiple (w.r.t. Time or Number of Operations)
Setups - multiple (w.r.t. Part Change, Time, Number of Operations)
Shift patterns

Linked Objects

Cost Information

» Conveyors - Floor & Overhead

>

>

>

Name, Type and Internal Type
Breakdowns - multiple (w.r.t. Time or Number of Operations)
Speed
Spaces (distance between parts)
Shift patterns
Cost Information
34

© UGS Corp. 2005. All rights reserved.



LY

Y~ Sample of SDX properties

» Transporters

» Name, Internal Type, and Image File

» Breakdowns - multiple (w.r.t. Time or Number of Operations)
» Capacity

»  Quantity

» Load / Unload times

» Speeds - Load / Unload / Acceleration / Deceleration

» Size

» Shifts

» Linked Objects

» Cost Information

35
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Y~ Sample of SDX properties

» Carriers

» Name, Internal Type, and Image File
» Capacity

» Quantity

» Load / Unload times

» Size

» Linked Objects

» Cost Information

» Buffers

» Name, Internal Type
» Minimum and Maximum Dwell time
»  Minimum and Maximum number of loads
» Image file
36
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1" SDX Route Handling

95%

10, PART_1, DOCK, W, 1.0, 1.0, 1.0, , 1.0, ,,, 20, PART_3
20, PART_1, W, A, 10, 10, 1.0, , 1.0, ,,, 30, PART_3
30, PART_1, A, Q, 1.0, 1.0, 1.0, ,1.0,,,,40, PART_3

40, PART_1, Q, R, 0.05, 1.0, 1.0, , 1.0, , , , 50, PART_3 <

40, PART_1,Q, S,0.95,1.0,1.0,, 20,,,, 60, PART_3 AT STATION ‘S

50, PART 1,R, S,0.1,1.0,1.0,,2.0,,,, 60, PART_3 2 unit of PART_1 and
50, PART_1, R, SCRAP, 0.9,1.0,1.0,,,,,, NULL, PART 3 3 units of PART 2
60, PART_1, S, ASSY, 1.0,1.0,1.0,,,,,, NULL, PART_3

become 1 unit of PART_3

10, PART_2, DOCK, Z, 1.0, 1.0, 1.0, , 1.0, , , , 20, PART_3
20, PART 2,7,S,1.0,1.0,1.0,,3.0,,,, 30, PART_3

Part 2 =————>

30, PART_2, S, ASSY, 1.0,1.0,1.0,,,,,, NULL, PART_3 Q - Inspection
R - Rework
10, PART 3,S,T,1.0,1.0,1.0,, 1.0,,,, 20, PART_3
20, PART 3, T, U, 1.0, 1.0, 1.0,, 1.0, , , , 30, PART_3 DOCK, SCRAP, SHIP, ASSY (assemble),
30, PART 3,U, T,0.2,1.0,1.0,,10,,,, 20, PART_3 i | MesenEel Tk
30, PART_3, U, SHIP, 0.8, 1.0, 1.0, , ., , , NULL, PART_3

<Seq_Num>, <Load_Name>, <From>, <To>, <Percent_Rule>, <Transfer_Qty>, <Output_Qty>, <Part_Cycle Time> ,
<Qty Per_Prod>, <Scrap_Rate>, <Mh_Equip>, <Load_Setup_Time> , <Next_Seq>, <Assembly Name>

37
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Y~ SDX Features

» All objects are written out in SDX
» Labor object - with labor pools...

» Labor can be connected to different machines and conveyor
stations.

» Conveyor stations can be linked to machines
» Resources (machines) can be linked to resources

» Click and change SDX type for certain objects

» SDX Route Editor

» Single database used for ALL material flow studies (i.e. static
and discrete event)

38
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Y~ SDXimplementation

» 95% of companies in the US use AutoCAD for plant layouts
» Layout drives changes - ultimate model

» It's simple

» |t works !!

39

© UGS Corp. 2005. All rights reserved.



4~ HLA - High Level Architecture

» IMS - MISSION consortium

» Methodology to communicate between models at
run-time.

» EQ: Models created in different DES packages
Interacting in run-time

» Very “cutting-edge”, very “cool”

» Contact N.I.S.T., Gaithersburg, MD for more detalils.
» National Institute for Standards & Technology

» Or visit their website at http://www.mel.nist.gov/msid/

40
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9~ Benefits

» Save time validating your concept in an early planning
phase

» Save money reducing stock and investment for
equipment and inventory

» Increase revenues by increasing system throughput
» Present animated results to upper management
» Provide proof of concept = added value for your work

» Minimize risk & make reliable decisions, thus
Increasing your decision competence

41
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9~ Imagine this for the future....

» A single visualization environment
» Distributed simulation systems
» Different simulations from different sources interact
» Fly through facility and run simulation on demand
» Collaborating with various simulations simultaneously

» Discrete Event Simulation
» Robotic / equipment simulation
» Human simulation

» Machine simulation

» Retrieve data across the web to run simulations online
» Query and data-mine through the virtual environment
» Studying effects of changes (eg: process) in real time
» All from your PC

42
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Contact and training information

» Visit us on the web at
http://www.uqgs.com/products/tecnomatix/plant design/

» For more information, e-mail info@ugs.com or complete our
request info form at

https://www.ugs.com/forms/tecnomatix info.shtml

» Shree Moorthy, Product Manager moorthy@ugs.com
+1 (248) 945-6419

» For training information, visit http://training.ugs.com

43
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